Node-red-contrib-s7 not working with Node-RED run from the device agent or cloud instance

Hi, I have a created an instance in FlowFuse cloud which I have attached to a device (Raspberry Pi 4). When I try connect to my PLC using the node-red-contrib-s7 nodes, I get the message:

Error: Timeout connecting to the transport

I tested the flow on a local instance of Node-RED where everything works just fine. Anyone have any idea how I can solve this and what can be the cause? I am connected to the same internet and using the correct IP adress of the PLC. I tried to do this starting the instance both manually and as a service, neither with no succes.


Just to be clear, this is a problem with Node-RED run from the device agent running on the Raspberry Pi not the cloud instance (as the title implies)?

And the same node running in a stand alone Node-RED instance on the same Pi works?

And the PLC in question is on the same LAN as the Raspberry Pi?

Yep, I run the device agent on a Raspberry Pi. I applied a snapshot of the cloud instance to the device. It worked neither from the cloud instance editor or from the device editor.
And yes, the node works when I run it in a stand alone local instace of Node-RED on the same Pi.
And yes, they are both on the same LAN.

It’s unlikely to work from the cloud instance editor because it won’t have access to the PLC on your local network (or at least I hope it doesn’t) from the AWS Data Centre in Ireland.

Is there anything else in the Node-RED logs for the device apart from the timeout message?

Haha yes, it makes sense that it has no access in the cloud editor! Just wanted to specify. And no, only thing shown in the logs is the above descriped error msg.

I’m only going to suggest this next thing as I’m trying everything, but you are 100% sure you’ve configured the same IP address between local and device agent?

Otherwise it will probably take a look at the s7 node’s code to see if we can work out where to stick some extra debug.

Do you mean the IP of the PLC? Yes, I am 100% sure I use the same IP address. I checked this multiple times and have copied it over.

A quick update. I just realised that the problem in fact seems to have nothing to do with FlowFuse, my apologies! I ran my test again and found out the instance in fact did NOT work on the local instance on the Pi. Just to be sure, I installed the device agent on the same computer from which I run the TIA Portal and attached the instance to the computer. Here, it works… So it seems devices other than the computer from which i run the TIA Portal are unable to communicate with the PLC and the s7 node. In TIA I realise I configured the PG/PC Interface to be the the wireless network card of my computer, however I am not able to change it to something else - wondering if this has to do with the problem. Dunno if you guys in this forum are able to provide any help with this…

I figured I did not configure the CPU on the correct subnet. Assigned new ip address and configured the router/gateway.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.