Updating Function node

I’ve been a long time user of NR and had tried to install the ChatGPT flows that were blogged about recently. This resulted in the discovery that my instance of NR was massively out of date and I opted to upgrade to V3.1 So far so good… I’ve now noted that the Function Node doesn’t allow any text input and I found a hint that the node should be updated. I guess this means attempting to delete and reinstall the node(?) but I’m finding this not possible as the manage palette display shows a greyed out “in use” against the function node. I’ve disabled (as far as I can tell) all the flows where Function Node is deployed but that hasn’t freed up the node for delete/re-install [I’m assuming this is the way forward? Otherwise, I’m considering backing up the 20 or so flows and installing on my Pi from scratch]… Any ideas please? Thanks

I think I solved this for myself. Updating all the nodes marked for updating seems to have enabled the editor in my Function Node. :frowning: