UIBUILDER cannot save or install packages

I run Node-RED with a flowfuse agent installed on a Raspberry Pi.
I am trying to set up a stand-alone web server by using the uibuilder node. I chose a blank template and go to “Files”. Here, whenever I try to edit and save the index.css/html/js and save I get the error “File Save FAILED” as shown on the picture below:

I tried to work around this by editing the files directly in the /opt/flowforge-device/project/uibuilder folder. This worked, however I discovered a new problem. I want to display the value of a variable on the web server, i.e. “msg.payload”. However, only the variable name (msg.payload) is shown and not the actual value of the variable. I solved this earlier on a local instance of Node-RED by installing the bootstrap and vue library, however even when I do this the value of the variable is still not shown.

Any ideas what causes the problem and what I can do to resolve it? Thanks!

The problem with editing files in in the node config dialogue should have been fixed in the latest version of the device-agent (published yesterday)

As for how to show the variable I’m sorry I can’t help as I don’t use UIBuilder

Thank you, Ben. I updated the agent and now I am able to edit the files directly in the editor. However, the variable still does not update despite the fact that I installed the bootstrap and vue packages. I have an identical flow on a local instance on my computer (not runnning the device agent) - here it works! So wondering if this is specific to Flowfuse.

It shouldn’t be FF specific.

If you post the content then somebody with some UIBuilder experience may be able to help.