Fresh FF install can not start Node-RED Instance

Been testing FlowFuse on Windows 11 Ok for a few weeks (have many questions about dashboard v2 and FlowFuse dash only members in due course).

Felt ready to move to the first steps of production.

  1. VM in a datacenter.
Linux 5.15.0-86-generic #96-Ubuntu SMP Wed Sep 20 08:23:49 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

node -v
npm -v

● flowforge.service - FlowForge Platform
     Loaded: loaded (/lib/systemd/system/flowforge.service; disabled; vendor preset: enabled)
     Active: active (running) since Tue 2023-10-17 19:33:13 CDT; 5s ago
   Main PID: 4229 (
      Tasks: 12 (limit: 36006)
     Memory: 119.1M
        CPU: 3.014s
     CGroup: /system.slice/flowforge.service
             ├─4229 /bin/sh /opt/flowfuse/bin/
             └─4237 node ./app/node_modules/.bin/flowforge

Oct 17 19:33:14 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:14.781Z","msg":" Projects   : 0/50"}
Oct 17 19:33:14 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:14.781Z","msg":" Devices    : 0/50"}
Oct 17 19:33:15 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:15.098Z","msg":"Email not configured"}
Oct 17 19:33:15 FlowForge[4237]: {"level":"WARN","time":"2023-10-18T00:33:15.098Z","msg":"[comms] Broker not configured - comms unavailable"}
Oct 17 19:33:15 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:15.183Z","msg":"Container driver: localfs"}
Oct 17 19:33:16 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:16.133Z","msg":"Server listening at"}
Oct 17 19:33:16 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:16.133Z","msg":"****************************************************"}
Oct 17 19:33:16 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:16.133Z","msg":"* To finish setting up FlowForge, open this url:   *"}
Oct 17 19:33:16 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:16.133Z","msg":"*                 *"}
Oct 17 19:33:16 FlowForge[4237]: {"level":"INFO","time":"2023-10-18T00:33:16.133Z","msg":"****************************************************"}

Not sure if its related or not, but as soon as I configure email (using the working config from my win11 setup) FlowFuse will not start which is going to be a problem when I get to invite dashboard only team members, so a problem for another time.

The FlowFuse install seemed to go well, no errors or complaints.

Looking in the docs for help:

Here is the single log that I have - Note I have tried a few times to start the instance.

Generally just confused why everything has been working great on Windows, but not on Linux.

Note that it seemed wrong to install in /opt/flowforge, so I have installed in /opt/flowfuse

Thanks for the assistance.

Can you post your flowforge.yml file please (with the passwords removed)

And if you look in /opt/flowfuse/var/projects there will be a directory with a UUID that matches the one in the URL on the instance page. From there include the out.log and if there is a settings.js

Thanks for the reply.
30 minutes after seeing that out.log file I am up and running.

The problem was two fold.

  1. I did not understand that the top of the yml file (domain and host) were critical.
    I saw the there and so I put in my (not yet registered) domain name.
    Looking at the out.log file I saw Node-RED trying to get its settings from that URL, could not find them, so failed to start.
    Once I changed the yml file for the IP address of the VM I was running on, Node-RED started Ok. Seems that ‘’ is ok to have there, but not an inactive domain name.
  2. Once Node-RED started, I could not open the editor. FlowFuse still showed the domain name, not the IP address. I stopped FlowFuse and reinstalled, still showing the domain when the yml file clearly had the IP address.
    I tried editing forge.db, but in the end, deleted it and installed FlowFuse again and I am 100% up and running. Even email is working now.

The key to getting everything working sort of smoothly was simply knowing where to find the FlowFuse out.log file. That one bit of information could have saved around 2 hours.
Be handy if that was in the docs link menitioned in my first post.

Looking forward to testing things out further.