Connecting to FlowForge with the Tools Module


I’m trying to connect my local Node-Red to my FF-server. I installed the tools, I’m able to enter a server, and I do get a popup where I have to allow the connection in FF.
However, when I click ‘ALLOW’, nothing happens, I’m still not connected and the popup closes. I don’t see any more explanation. Where should I be looking?


I’ve just checked and the tool seems to be working for me on FlowForge Cloud. It looks as if you are accessing your own installation of FlowForge using IP addresses rather than a domain name. I wonder if that might be the problem. Is there any reason you are not using a domain name to access your FlowForge install?


It’s indeed not a cloud instance, but hosted on our own cloud. The domain name points to an nginx server that reroutes traffic to that ip. When I try using the nginx domain name, it doesn’t do anything at all, so I thought it would be better to connect to the vpn and use the direct ip.

FlowForge tends to not work well when not using a domain name. It uses domain aliases to route traffic to the relevant resources. If FlowForge is not working at all via your domain I suspect something is not correct with the configuration of your FlowForge installation or your DNS. I’d suggest you get FlowForge working on the domain first then see if the FlowForge Tools plugin is still not working as expected. Hope that’s helpful.

Is there anything in the browser console when it fails?

Before hitting the Allow button if you press f12 it should open the console.

Also worth looking at the FlowForge logs at the same time.

And can you give some information about what versions of everything you are running please and on what OS. I assume from the port 3000 that this is running the localfs build (not docker/kubernetes)?

1 Like

I’m getting this in F12:

Where do I find FF logs?

|Forge Application|v1.8.2|
Node-Red version 3.0.2

For the logs we need to know how you installed it, assuming it’s was the localfs build from GitHub - flowforge/installer: A set of install scripts for FlowForge and you set it to run as a service.

journal -u flowforge should work

I don’t fully understand. FlowForge is accessible through a domain name, via an nginx in front of it, which is facing the internet. Would that not work?

Sorry, FF is installed with the Linux install instructions: Local Install • FlowForge Docs.

So no Kubernetes or Docker indeed.
Journal gives me this:

root@pack:~# journal -u flowforge
15:52:36.066 › primary open
[3563496:0802/] Missing X server or $DISPLAY
[3563496:0802/] The platform failed to initialize.  Exiting.
The futex facility returned an unexpected error code.Aborted (core dumped)

Apologies it should have been

journalctl -u flowforge

Oh, ok, Nothing special in there.