Device Agent Install - GLIBCXX_3.4.26 not found

RaspberryPi 4/ARM/Raspbian GNU/Linux (buster) 10
I fully realise this is a RaspPi question, which I’ve been struggling with all afternoon.

When installing the device agent I get the following error -
Error is "/usr/lib/arm-linux-gnueabihf/ version : GLIBCXX_3.4.26 not found.

Based on this search :
strings /usr/lib/arm-linux-gnueabihf/ | grep GLIBCXX
I can see the highest GLIBCXX_3.4.25 is the highest entry. So based on this reference for compiler compatibility : ABI Policy and Guidelines I reckon my compiler is a lower version than required?

Many threads in the raspberry forums - where you need to have a few years compiler knowledge to decipher…

Based on those hints I’ve installed gcc 9.1.0 to replace to default lower version gcc version 8.3.0
No improvement, same error.

Do I need to install/recompile some source to get the device agent installed?

Any help/guidance appreciated.


I belive it has to do with your nodejs version . You might have 20 .x

On buster belive you need to have 16 or 18 to make it work properly . As there are something that does not work for 20.x when you are not using bullseye .

I resently had similar issue when installing node-red and downgrading to 16 fixed it for me .

1 Like

Thanks oivheg for your help!

nvm ls lists the different versions of nodejs I had downloaded.

nvm use 16.20.2 tells it select v16

sudo npm install -g @flowforge/flowforge-device-agent worked like a dream!

Thanks again